R-1.4.0 for MacOS X

About this list Date view Thread view Subject view Author view Attachment view

From: Jan de Leeuw (deleeuw@stat.ucla.edu)
Date: Sat 22 Dec 2001 - 17:00:37 EST


Message-id: <385A0FB0-F6A1-11D5-BA85-00039364CC92@stat.ucla.edu>


Get it from ftp://gifi.stat.ucla.edu in pub.

This contains the base files plus the recommended packages (except rpart,
which does not compile yet).

It is compiled under MacOS X 10.1.2 with the December 2001 version of
the Developer Tools, and with g77 from fink.sourceforge net. It has
support
for gnome, X11R6, and tcl/tk, and it uses the newest ATLAS from fink. It
has two-level namespaces and has a libR.dylib included.

For R,bin you need on your system (remember to set DYLD_LIBRARY_PATH,
or --better-- install fink and compile these things yourself)

        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
version 55.0.0)
         /sw/lib/libz.1.dylib (compatibility version 1.1.3, current
version 1.1.3)
         /sw/lib/libreadline.4.dylib (compatibility version 4.2.0,
current version 4.2.0)
         /sw/lib/libdl.dylib (compatibility version 0.0.0, current
version 0.0.0)
         /sw/lib/libncurses.dylib.5 (compatibility version 5.0.0, current
version 5.2.0)

and for the two main modules

R_X11.so:
         /usr/X11R6/lib/libSM.6.dylib (compatibility version 6.0.0,
current version 6.0.0)
         /usr/X11R6/lib/libICE.6.dylib (compatibility version 6.3.0,
current version 6.3.0)
         /usr/X11R6/lib/libX11.6.dylib (compatibility version 6.2.0,
current version 6.2.0)
         /sw/lib/libjpeg.62.dylib (compatibility version 63.0.0, current
version 63.0.0)
         /sw/lib/libpng.2.dylib (compatibility version 1.0.12, current
version 1.0.12)
         /sw/lib/libz.1.dylib (compatibility version 1.1.3, current
version 1.1.3)
         libR.dylib (compatibility version 0.0.0, current version 0.0.0)
         /sw/lib/libreadline.4.dylib (compatibility version 4.2.0,
current version 4.2.0)
         /sw/lib/libdl.dylib (compatibility version 0.0.0, current
version 0.0.0)
         /sw/lib/libncurses.dylib.5 (compatibility version 5.0.0, current
version 5.2.0)
         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
version 55.0.0)
R_gnome.so:
         /sw/lib/libgnomeui.32.dylib (compatibility version 47.0.0,
current version 47.1.0)
         /sw/lib/libart_lgpl.2.dylib (compatibility version 5.0.0,
current version 5.0.0)
         /sw/lib/libgdk_imlib.1.dylib (compatibility version 11.0.0,
current version 11.10.0)
         /usr/X11R6/lib/libSM.6.dylib (compatibility version 6.0.0,
current version 6.0.0)
         /usr/X11R6/lib/libICE.6.dylib (compatibility version 6.3.0,
current version 6.3.0)
         /sw/lib/libgtk-1.2.0.dylib (compatibility version 10.0.0,
current version 10.1.0)
         /sw/lib/libgdk-1.2.0.dylib (compatibility version 10.0.0,
current version 10.1.0)
         /sw/lib/libgmodule-1.2.0.dylib (compatibility version 1.0.0,
current version 1.10.0)
         /sw/lib/libdl.dylib (compatibility version 0.0.0, current
version 0.0.0)
         /sw/lib/libintl.1.dylib (compatibility version 2.0.0, current
version 2.1.0)
         /usr/X11R6/lib/libXext.6.dylib (compatibility version 6.4.0,
current version 6.4.0)
         /usr/X11R6/lib/libX11.6.dylib (compatibility version 6.2.0,
current version 6.2.0)
         /sw/lib/libgnome.32.dylib (compatibility version 37.0.0, current
version 37.3.0)
         /sw/lib/libgnomesupport.0.dylib (compatibility version 1.0.0,
current version 1.0.0)
         /sw/lib/libesd.0.dylib (compatibility version 3.0.0, current
version 3.22.0)
         /sw/lib/libaudiofile.0.dylib (compatibility version 1.0.0,
current version 1.1.0)
         /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
version 55.0.0)
         /sw/lib/libglib-1.2.0.dylib (compatibility version 1.0.0,
current version 1.10.0)
         /sw/lib/libglade-gnome.0.dylib (compatibility version 5.0.0,
current version 5.2.0)
         /sw/lib/libglade.0.dylib (compatibility version 5.0.0, current
version 5.2.0)
         /sw/lib/libxml.1.dylib (compatibility version 10.0.0, current
version 10.16.0)
         /sw/lib/libz.1.dylib (compatibility version 1.1.3, current
version 1.1.3)
         libR.dylib (compatibility version 0.0.0, current version 0.0.0)
         /sw/lib/libreadline.4.dylib (compatibility version 4.2.0,
current version 4.2.0)
         /sw/lib/libncurses.dylib.5 (compatibility version 5.0.0, current
version 5.2.0)

tcl/tk support uses

        /sw/lib/libtcl8.3.dylib (compatibility version 8.0.0, current
version 8.3.0)
         /sw/lib/libtk8.3.dylib (compatibility version 8.0.0, current
version 8.3.0)

Everything in /usr/X11R6 comes from Xfree86 (Xtools would also be OK),
everything
in /sw/lib comes from fink.

===
Jan de Leeuw; Professor and Chair, UCLA Department of Statistics;
US mail: 9432 Boelter Hall, Box 951554, Los Angeles, CA 90095-1554
phone (310)-825-9550; fax (310)-206-5658; email: deleeuw@stat.ucla.edu
homepage: http://www.stat.ucla.edu/~deleeuw
========================================================
           No matter where you go, there you are. --- Buckaroo Banzai
                    http://www.stat.ucla.edu/~deleeuw/sounds/nomatter.au
========================================================

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-announce mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !) To: r-announce-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._


About this list Date view Thread view Subject view Author view Attachment view

This archive was generated by hypermail 2.1.3 : Thu 17 Jan 2002 - 11:16:02 EST