Re: [Rd] 2.0.1 buglets

From: Kurt Hornik <Kurt.Hornik_at_wu-wien.ac.at>
Date: Fri 05 Nov 2004 - 18:53:59 EST

>>>>> Peter Dalgaard writes:

> Peter Dalgaard <p.dalgaard@biostat.ku.dk> writes:

>> > > but everything seems to configure and make ok. Should this message be 
>> > > expect or is this a bug?
>> > 
>> > It is unexpected.  Is it new in 2.0.1 beta?  You have told us your kernel,
>> > not your distro.  This looks like a bug, but not in R.
>> 
>> I've seen it whizz by occasionally but never got around to
>> investigate. As said, it doesn't actually affect the result of
>> configure.

> I can't seem to reproduce this exactly, but on Solaris I have

> checking for xmkmf... /usr/X/bin/xmkmf
> /home/bs/sfesys/sysadm/export/common.alias: No such file or directory
> /home/bs/sfesys/sysadm/export/common.alias: No such file or directory
> /home/bs/sfesys/sysadm/export/common.alias: No such file or directory
> /home/bs/sfesys/sysadm/export/common.alias: No such file or directory

> This was with the 2.0.0 sources, so it isn't new. The culprit appears
> to be constructions like

> if test "`which ${cc}`" = "`which ${CC}`"; then
> shlib_ldflags=`${srcdir}/tools/GETMAKEVAL SHLIBLDFLAGS`
> cpicflags=`${srcdir}/tools/GETMAKEVAL PICFLAGS`
> fi

> in configure.ac. I guess we shouldn't really use "which" at all...

In which case we need other means to figure out whether ${cc} and ${CC} are the same. (In the sense that they have the same pathname.)

Shell scripts for doing so will be appreciated.

(Actually, I would think that the above points to an incorrect imake configuration.)

-k



R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Nov 05 18:59:46 2004

This archive was generated by hypermail 2.1.8 : Fri 05 Nov 2004 - 19:08:18 EST