Re: [Rd] 2.0.1 buglets

From: Martin Maechler <maechler_at_stat.math.ethz.ch>
Date: Fri 05 Nov 2004 - 19:54:03 EST

>>>>> "PD" == Peter Dalgaard <p.dalgaard@biostat.ku.dk> >>>>> on 04 Nov 2004 23:17:45 +0100 writes:

    PD> Prof Brian Ripley <ripley@stats.ox.ac.uk> writes:
>> On Thu, 4 Nov 2004, Paul Gilbert wrote:
>>
>> > With R-2.0.1 (patched) on Linux rhlinux 2.4.21-4.ELsmp
>> >
>> > when I configure get > ... > checking whether C
>> runtime needs -D__NO_MATH_INLINES... no > checking for
>> xmkmf... /usr/bin/X11/xmkmf > Usage: which [options] [--]
>> programname [...] > Options: --version, -[vV] Print
>> version and exit successfully. > --help, Print this help
>> and exit successfully. > --skip-dot Skip directories in
>> PATH that start with a dot. > ...
>> >
>> > but everything seems to configure and make ok. Should
>> this message be > expect or is this a bug?
>>
>> It is unexpected. Is it new in 2.0.1 beta? You have
>> told us your kernel, not your distro. This looks like a
>> bug, but not in R.

    PD> I've seen it whizz by occasionally but never got around     PD> to investigate.

me too. IIRC, also in some of my current Linux setups. I think it's showing unfortunate behavior of configure .. (ie. a "buglet" in the configure tools used to produce 'configure',  and not in our 'configure.ac' source).

    PD> As said, it doesn't actually affect the result of configure.

my experience as well.
Martin



R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Nov 05 20:10:31 2004

This archive was generated by hypermail 2.1.8 : Fri 05 Nov 2004 - 21:08:36 EST