Re: [Rd] Re: [R] Building a package under WIN2000 / rw2.0

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Mon 08 Nov 2004 - 01:18:05 EST


On Sun, 7 Nov 2004, Uwe Ligges wrote:

> BXC (Bendix Carstensen) wrote:
> > I have an odd problem in building a package with only R-code in it.
> > I have a package mainly used by myself which I last build under R
> > 1.9.0.
> > The operation system is Win2000 5.00.2195, Service Pack 3
> >
> > When I do:
> >
> > c:\stat\r\rw2000\bin\Rcmd install --docs=normal --build
> > --library=c:\stat\R\bxc\library c:\stat\R\bxc\library.sources\xx
>
> [moved to R-devel]
>
> Works with forward slashes as follows:
>
> c:\stat\r\rw2000\bin\Rcmd install --docs=normal --build
> --library=c:\stat\R\bxc\library c:/stat/R/bxc/library.sources/xx
>
> The seems to be related with the more recent threads
> "Re: [Rd] wishlist: better error message in R CMD check"
> "[Rd] creating a package without lazy loading"
> on R-devel.
>
> I'll try to debug.

I have a fix in R-patched for this: it seems highly dependent on the version of the tools in use.

For rw2000, do avoid

Both were warned against, of course.

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon Nov 08 01:23:57 2004

This archive was generated by hypermail 2.1.8 : Mon 08 Nov 2004 - 02:12:32 EST