RE: [Rd] RFC install.packages() changes

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Mon 08 Nov 2004 - 18:08:56 EST


On Sun, 7 Nov 2004, Liaw, Andy wrote:

> One thing that concerns me a bit (I haven't check whether the concern is
> warranted) is package dependency: If the new version of a package on CRAN
> requires, e.g., a newer version of R than what the user has, what happens
> then?

You are not offered a choice of updating. That needs documenting.

Brian

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon Nov 08 18:14:35 2004

This archive was generated by hypermail 2.1.8 : Mon 08 Nov 2004 - 19:09:17 EST