Re: [Rd] R 'postscript' plot - not a valid postscript (PR#7559)

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Tue 25 Jan 2005 - 03:23:26 EST

dan@bolser.co.uk writes:

> Full_Name: Mr. Daniel Murray Bolser
> Version: R 2.0.0 (2004-10-04)
> OS: Linux beagle 2.4.20-31.9 #1 Tue Apr 13 17:38:16 EDT 2004 i686 athlon i386 GNU/Linux
> Submission from: (NULL) (193.60.81.207)
>
>
>
> Trying to execute the following code produces a 'not a valid postscript' error
> from various postscript readers (gv, ggv, ghostscript). A very similar code
> works fine.
>
> <CODE>
>
> postscript()
>
> plot( 1:100, ylim=c(1,700), type='n', log='y')
>
> abline(v=seq(0,100,10))
> abline(h=10)
> abline(h=seq(0,100, 10)) # Comment out this line and it works fine
>
> dev.off()
>
> </CODE>
>

Just abline(h=0) gives the same effect, with the following in the postscript file

77.04 nan m
716.61 nan l

which of course comes from trying to calculate log10(0).

> Looking at this just now I see the problem, but if a ps file is written, it
> should be viewable, so I think this is still a bug.

Yes. However, the workaround would be rather obvious...

-- 
   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)             FAX: (+45) 35327907

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Tue Jan 25 02:34:14 2005

This archive was generated by hypermail 2.1.8 : Fri 18 Mar 2005 - 09:02:41 EST