[Rd] 2.1.0a for Macs (PR#7952)

From: <jbaltzer_at_oeb.harvard.edu>
Date: Thu 16 Jun 2005 - 21:30:19 GMT


I am writing regarding serious problems that a number of researchers at a workshop held by the Smithsonian Tropical Research Institute are encountering with the most recent R version for Macs (the patched version of 2.1.0 (2.1.0a) that you indicate should be used over 2.1.0).

The following problems are not specific to my computer but are being experienced by ALL Mac users at this workshop running 2.1.0a to varying degrees. I installed the program about a week ago and immediately I started getting a warning messages particularly when browsing my files using ls(), search(), gc(), etc. 2.1.0a automatically adds an open parentheses at the end of any command requiring () (only intermittently, however) and then generates a warning in red. I am afraid that I do not have the warning because R no longer will open on my computer without reinstallation so I am forced to use a PC. The same warning message has been posted by one other on the help email list. More recently, R has begun to crash for no particular reason (no large program running). Often when I then try to restart R 2.1.0a crashes during start up and in order to get it functioning again I have to reinstall! The first time this happened I decided to go back to an earlier version of R that I knew would be stable but following binary compilation no gui is installed on my computer and I can't run the program. The only version my computer can now install properly is 2.1.0a but as described above the problems with the program prohibit me from using it.

If you could please advise on how to deal with these problems (particularly the corruption of my system by 2.1.0a) all the Mac users at this conference would be appreciative.

Jennifer Baltzer



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Jun 17 07:38:32 2005

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 03:21:09 GMT