Re: [Rd] loess returns different standard errors for identical models (PR#7956)

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Sun 19 Jun 2005 - 08:30:59 GMT

Peter Dalgaard <p.dalgaard@biostat.ku.dk> writes:

> Peter Dalgaard <p.dalgaard@biostat.ku.dk> writes:
>
> > Prof Brian Ripley <ripley@stats.ox.ac.uk> writes:
> >
> > > I've seen many similar things in a report from valgrind. But they
> > > went away when compiled without optimization: it seems optimization
> > > often does a fetch one element off the end of an array when attempting
> > > to keep the pipelines full.
> >
> > > I'd start by re-running the valgrind tests without optimization.
> >
> > I was going to anyway, but the reported problem did carry all the
> > hallmarks of the use of a memory location with random content.
>
> Still present with "-g" recompile, and a breakpoint in lowesb showed
> that the last call had garbage in the "iv" array.

The latter turned out to be a red herring. Apparently a gdb bug messed up the "x/50d" command that I was using to inspect the array. The real problem was in other arguments, namely "diagl" and "trl" which are declared double precision, but passed "&zero" where "zero" is declared to be of type "Sint".

Now, the 64000$ question is whether it is safe to try and fix it for 2.1.1...

-- 
   O__  ---- Peter Dalgaard             ุster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard@biostat.ku.dk)                  FAX: (+45) 35327907

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sun Jun 19 18:34:18 2005

This archive was generated by hypermail 2.1.8 : Mon 24 Oct 2005 - 22:27:20 GMT