Re: [Rd] Open device -> glibc 2.3.4 bug for Redhat Enterprise 4?

From: Thomas Lumley <tlumley_at_u.washington.edu>
Date: Tue 21 Jun 2005 - 16:59:31 GMT

This was supposed to be fixed in 2.1.1 -- which version are you using?

         -thomas

On Tue, 21 Jun 2005, Martin Maechler wrote:

> We have been using Redhat Enterprise 4, on some of our Linux
> clients for a while,
> and Christoph has just found that opening an R device for a file
> without write permission gives a bad glibc error and subsequent
> seg.fault:
>
>> postscript("/blabla.ps")
> *** glibc detected *** double free or corruption (!prev): 0x0000000001505f10 ***
>
> or
>
>> xfig("/blabla.fig")
> *** glibc detected *** double free or corruption (!prev): 0x0000000001505f10 ***
>
> and similar for pdf();
> does not happen for jpeg() {which runs via x11},
> nor e.g. for
>
>> sink("/bla.txt")
>
> -------
>
> Happens both on 32-bit (Pentium) and 64-bit (AMD Athlon)
> machines with the following libc :
>
> 32-bit:
> -rwxr-xr-x 1 root root 1451681 May 13 00:17 /lib/tls/libc-2.3.4.so*
> 64-bit:
> -rwxr-xr-x 1 root root 1490956 May 12 23:26 /lib64/tls/libc-2.3.4.so*
>
> -------
>
> Can anyone reproduce this problem?
>
> Regards,
> Martin
>
> ______________________________________________
> R-devel@r-project.org mailing list
>
https://stat.ethz.ch/mailman/listinfo/r-devel
>



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed Jun 22 03:01:47 2005

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 03:21:09 GMT