Re: [Rd] Building R v2.1.1 for Windows

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sun 03 Jul 2005 - 18:55:51 GMT

Erich Neuwirth wrote:
> Recently, I notice strange things when I try to build R 2.1.1 on Windows XP.
> I downloaded and unpacked. R-2.1.1.tar.gz.
> All the tools are in place.
>
> I get as far as building the installer, and then the following happens:
>
> perl JRins.pl rw2011 rw2011
> "C:/Program Files/Inno Setup 5/iscc" R.iss > rw2011.log 2>&1
> make[2]: Leaving directory
> `/cygdrive/c/devel/R/R-2.1.1/src/gnuwin32/installer'
> make[2]: Entering directory
> `/cygdrive/c/devel/R/R-2.1.1/src/gnuwin32/installer'
>
> rm -rf R.iss Rsmall.iss *.log rw2011
> rm: cannot remove directory `rw2011/library/base/html': Directory not empty
> rm: cannot remove directory `rw2011/library/tcltk/Meta': Directory not empty
> make[2]: *** [clean] Error 1
> make[2]: Leaving directory
> `/cygdrive/c/devel/R/R-2.1.1/src/gnuwin32/installer'
> make[1]: *** [rinstaller] Error 2
> make[1]: Leaving directory `/cygdrive/c/devel/R/R-2.1.1/src/gnuwin32'
> make: *** [distribution] Error 2
>
> Looking into the two supposedly nonempty directories
> I see that in fact that are empty.
> Of course, I only can look a little bit later, so this might be a timing
> issue.
> Has anyone experienced similar problems?
> This effect is somewhat random. The supposedly nonempty directories
> change from build attempt to build attempt.
>
> So far, this has not happened when I build R-patched and R-devel which
> I update from SVN.

I haven't seen that error so far during an R build, but I believe you'll get it if the directory is busy because it is the current directory for some process. Did you have another window open that was looking at it?

Duncan Murdoch



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon Jul 04 04:58:40 2005

This archive was generated by hypermail 2.1.8 : Mon 24 Oct 2005 - 22:27:25 GMT