[Rd] Different gcc versions

From: Göran Broström <gb_at_stat.umu.se>
Date: Sat 20 Aug 2005 - 11:54:20 GMT


I have both gcc-3.4 and gcc-4.0(.1) installed on my system (debian-amd64 unstable), with links /usr/bin/gcc, g77, etc. to the 3.4 versions. When I build R, the 3.4 version is picked up, which is fine.

However, when I 'install.packages("xyz")', R uses gcc-4.0 and gfortran-4.0! Should I accept this or do something about it? And if so, what? Of course, removing all 4.0 versions would help, but what if I don't want to do that?

> version

         _
platform x86_64-unknown-linux-gnu

arch     x86_64
os       linux-gnu

system x86_64, linux-gnu
status
major 2
minor 1.1
year 2005
month 06
day 20
language R  
-- 
Göran Broström                    tel: +46 90 786 5223
Department of Statistics          fax: +46 90 786 6614
Umeå University                   http://www.stat.umu.se/~goran.brostrom/
SE-90187 Umeå, Sweden             e-mail: gb@stat.umu.se

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sat Aug 20 21:58:17 2005

This archive was generated by hypermail 2.1.8 : Mon 20 Feb 2006 - 03:21:16 GMT