Re: [Rd] Different gcc versions

From: Dirk Eddelbuettel <edd_at_debian.org>
Date: Sat 20 Aug 2005 - 14:09:21 GMT

Göran,

On 20 August 2005 at 13:54, Göran Broström wrote:
| I have both gcc-3.4 and gcc-4.0(.1) installed on my system
| (debian-amd64 unstable), with links /usr/bin/gcc, g77, etc. to
| the 3.4 versions. When I build R, the 3.4 version is picked up,
| which is fine.
|
| However, when I 'install.packages("xyz")', R uses gcc-4.0 and
| gfortran-4.0! Should I accept this or do something about it?
| And if so, what? Of course, removing all 4.0 versions would
| help, but what if I don't want to do that?

There are several way about it.

The first would be to actually use one of Debian's packages -- unstable currently uses gcc 4.0.1 / g77 3.4.*. That seems to work well. You'd get the same released version for amd64 as well. I'd do that.

The second would be to continue building on your own, but to make sure the generated Makeconf (which the Debian package copies into /etc/R/) has the right settings.

Hope this helps, Dirk

-- 
Statistics: The (futile) attempt to offer certainty about uncertainty.
         -- Roger Koenker, 'Dictionary of Received Ideas of Statistics'

______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sun Aug 21 00:13:01 2005

This archive was generated by hypermail 2.1.8 : Mon 24 Oct 2005 - 22:27:40 GMT