Re: [Rd] missing sh.exe file when running "R CMD INSTALL test" (PR#8068)

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sun 21 Aug 2005 - 01:35:32 GMT

u9126801@stat.nctu.edu.tw wrote:
> I am trying to learn how to make a simple package that contains no C
> or Fortran code. I used package.skeleton(...) to make a package
> called "test". The directory and files look good. I downloaded and
> installed Rtools (www.murdoch-sutherland.com/Rtools/tools.zip). I
> added the path and from the dos prompt I can verify that make.exe and
> sh.exe both exist, but when I try to run "R CMD INSTALL test" I get an
> error "make: sh.exe: Command not found" and "make: *** [pkg-test]
> Error 127". I get the same error message if a try the command "make
> pkg-test".

You need to make sure the tools directory (wherever you put it) is on your path. Type PATH at a command prompt to see the current path; type

PATH= blah blah blah

to set a new one. See the R Admin manual for advice on what to put in it.

Duncan Murdoch
>
> I saw in an old FAQ a suggestion to move sh.eve to the C:\bin\ folder,
> but my C: root does not have a "bin" folder. Nonetheless, I created
> one and put sh.exe there and it provided no help (I didn't expect it
> too).
>
> Can anyone help me?
>
>
> [[alternative HTML version deleted]]
>
> ______________________________________________
> R-devel@r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sun Aug 21 11:46:51 2005

This archive was generated by hypermail 2.1.8 : Mon 24 Oct 2005 - 22:27:40 GMT