Re: [Rd] Problems with Windows Cross compile

From: Jun Yan <jyan_at_stat.uiowa.edu>
Date: Tue 20 Dec 2005 - 18:07:07 GMT

I've seen that error before. It has to do with the setup of R_EXE. A current linux R is required. The following order worked for me:

make linuxR
make LinuxFresh=YES mkrules
make R

Jun

On Tue, 20 Dec 2005, Warnes, Gregory R wrote:

>
> Well, I'm finally getting around to setting up a cross-compiler for Windows on my local Linux box. I'm using the Yan & Rossini's docuimentation and the latest 'http://cran.r-project.org/doc/contrib/Makefile-rcb' , which is working of the R-2.2.0 sources.
>
> After discovering that "cp -p" doesn't work on the filesystem I'm using and removing the '-p's in the R makefiles using perl, I've gotten things to run pretty far through. Unfortunately, I get stopped by this error when building the base packages:
>
> writing help indices for package: base tools utils grDevices graphics stats datasets methods grid splines stats4 tcltk
>
> ---------- Making package base ------------
> adding build stamp to DESCRIPTION
> installing inst files
> installing indices
> Error in get(x, envir, mode, inherits) : variable "win.packages.html" was not found
> Execution halted
>
> Any ideas?
>
> -Greg
>
> Gregory R. Warnes, Ph.D.
> Associate Director, Non-Clinical Statistics
> Pfizer Global Research and Development
>
> ----------------------------------------------------------------------
> LEGAL NOTICE
> Unless expressly stated otherwise, this message is confidential and may be privileged. It is intended for the addressee(s) only. Access to this E-mail by anyone else is unauthorized. If you are not an addressee, any disclosure or copying of the contents of this E-mail or any action taken (or not taken) in reliance on it is unauthorized and may be unlawful. If you are not an addressee, please inform the sender immediately.
>



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed Dec 21 05:15:13 2005

This archive was generated by hypermail 2.1.8 : Wed 21 Dec 2005 - 02:22:12 GMT