Re: [Rd] Solaris build problem

From: Dominick Samperi <djsamperi_at_gmail.com>
Date: Mon, 14 Jun 2010 11:37:32 -0400

On Mon, Jun 14, 2010 at 11:23 AM, Prof Brian Ripley <ripley_at_stats.ox.ac.uk>wrote:

> On Mon, 14 Jun 2010, Prof Brian Ripley wrote:
>
> At one level the answer is easy: cxxPack was not installed at system level
>> when that check was run, and I presume it was installed on the other build
>> systems.
>>
>> However, the vignette checker should be able to find the package from the
>> copy installed for checking, so I need to dig deeper to find out why that
>> did not happen.
>>
>
> And it because you have an inst/doc/Makefile that does not arrange to do
> so. R_LIBS should be set appropriately at that point, but since you are not
> using --vanilla to run R (unlike R CMD check), it is overridden by other
> settings.
>

But you said nothing about Solaris here. Why doesn't the problem arise with other OS's?

If I could setup an environment like the one used for Solaris I could test out issues like this
(and reduce r-devel traffic).

Thanks,
Dominick

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon 14 Jun 2010 - 15:58:45 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 15 Jun 2010 - 09:01:08 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive