Re: [Rd] CHM help does not find help docs in package stats

From: Thaler, Thorn, LAUSANNE, Applied Mathematics <Thorn.Thaler_at_rdls.nestle.com>
Date: Thu, 17 Jun 2010 09:19:07 +0200

Indeed, the R version is 2.9.2. But the package was built on the very same system. Besides, another package built with the same version of R but on another machine does not show this nasty behavior. Upgrading, however, could pose more problems as it solves, since even if I could upgrade locally, it would be a mess to assure that all colleagues upgrade as well.

Anyways, even if the chm format is not supported any more by current versions of R, it should work with older ones, right? So, what can I do additionally to get to the bottom of this problem?

Thanks + BR,

Thorn

-----Original Message-----
From: Uwe Ligges [mailto:ligges_at_statistik.tu-dortmund.de] Sent: samedi 12 juin 2010 18:21
To: Thaler,Thorn,LAUSANNE,Applied Mathematics Cc: r-devel_at_r-project.org
Subject: Re: [Rd] CHM help does not find help docs in package stats

Which version of R is this?
CHM help is R < 2.10.0. All versions thereafter do not support compiled html help anymore.

Please upgrade your version of R and try one of the currently supported help formats.

Best wishes,
Uwe Ligges

On 11.06.2010 12:06, Thaler, Thorn, LAUSANNE, Applied Mathematics wrote:
> Hi all,
>
> currently I'm working on an R package bundling some frequently used
> functions. When I load my package and type
>
> ?one_of_my_functions
>
> I get the particular help file. If I try to get help on another
> function, which is part of package stats (prcomp say), I get "This
> program cannot display the webpage". A help on ?mean does, however,
work
> as it opens a new window showing the help on mean.
>
> There is another peculiarity, if it happens that I requested a help
file
> for a function in the package stats before I used the help on one of
my
> functions, everything works out fine.
>
> Does anybody know how I can get rid of this annoying behavior? It has
to
> have something to do with my particular package, since everything
works
> as expected with another package of mine.
>
> I override one of the functions of stats (biplot.default), which is,
> however, not exported and resides within my namespace. Could that be
the
> reason?
>
> Any help highly appreciated. Thanks + BR,
>
> Thorn
>
> ______________________________________________
> R-devel_at_r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Thu 17 Jun 2010 - 07:21:37 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 18 Jun 2010 - 20:32:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive