[Rd] No output/no source tarball produced by 'R CMD build' on Windows (but ret code is 0)

From: Hervé Pagès <hpages_at_fhcrc.org>
Date: Mon, 21 Jun 2010 12:20:37 -0700


Hi,

After updating R-2.12 on the Bioconductor build system about 1 week ago (we update R every 4-6 weeks for our devel builds), we've started to see something never seen before on Windows: for some BioC packages, 'R CMD build' would produce no output at all (0 byte) and, of course, no source tarball. Even though, the code returned by the command is 0!

See an example of this is here:  

http://bioconductor.org/checkResults/2.7/bioc-LATEST/MotIV/liverpool-buildsrc.html

   (the content of this page is updated every day)

Note the:

   RetCode: 0
   PackageFile: None
and the lack of output!

This seems to happen randomly for a couple of packages every day. Today it's for MotIV only. Last time I checked, it was charm and genefilter. Before that, they were 2 other packages.

Note that the only thing that changed on our Windows build machine liverpool (Windows Server 2003 R2 (32-bit)) is that R-2.12.0 was updated to 2010-06-11 r52254.

Let me know if I can help in any way.

Thanks,
H.

-- 
Hervé Pagès

Program in Computational Biology
Division of Public Health Sciences
Fred Hutchinson Cancer Research Center
1100 Fairview Ave. N, M2-B876
P.O. Box 19024
Seattle, WA 98109-1024

E-mail: hpages_at_fhcrc.org
Phone:  (206) 667-5791
Fax:    (206) 667-1319

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon 21 Jun 2010 - 19:23:17 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Fri 25 Jun 2010 - 13:21:26 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive