[Rd] incorrect DLL path for Rbitmap.dll on Windows

From: Dan Tenenbaum <dtenenba_at_fhcrc.org>
Date: Mon, 08 Nov 2010 12:14:51 -0800


Hello,

I think there is a problem in recent devel builds of R on Windows with various devices from the grDevices package. For example:

> capabilities()

    jpeg      png     tiff    tcltk      X11     aqua http/ftp  sockets
    TRUE     TRUE     TRUE     TRUE    FALSE    FALSE     TRUE     TRUE
  libxml     fifo   cledit    iconv      NLS  profmem    cairo
    TRUE    FALSE     TRUE     TRUE     TRUE     TRUE    FALSE

> jpeg()

Error in jpeg() : unable to start jpeg() device In addition: Warning messages:
1: In jpeg() : Unable to load Rbitmap.dll 2: In jpeg() : opening device failed

In the GUI version, a dialog appears saying: Unable to load
'C:\PROGRA~1\R\R-213~1.0DE\library\grDevices\libs\Rbitmap.dll'

It seems that there should be an architecture folder (i386 or x64) after "libs", because that is where the dll is located.

Same thing happens with png(), tiff(), etc.

> sessionInfo()

R version 2.13.0 Under development (unstable) (2010-11-07 r53537) Platform: i386-pc-mingw32/i386 (32-bit)

locale:

[1] LC_COLLATE=English_United States.1252
[2] LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

Thanks!
Dan

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon 08 Nov 2010 - 20:21:32 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 10 Nov 2010 - 02:30:19 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive