[Rd] Crash when using embedded R.

From: Dave Pugmire <dpugmire_at_gmail.com>
Date: Mon, 30 Jan 2012 17:20:10 -0500


Hi,
I'm new to R, and am trying to embed R into another application. I'm calling gev.fit() from the ismev package, and it is crashing somewhere inside it.
gdb is not catching it, and valgrind is not showing any memory corruption issues.
I suspect it's memory corruption, because it doesn't die in exactly the same spot each time.

Also, before I make the gev.fit() call, I save out the R state using "save.image(....)", then load the image file, and call gev.fit(), and it works fine.
So, it's something to do with my app, and the R.

I'm looking for hints/ideas/tricks/etc for debugging this. I'm starting to put print statements into the R code, and into the C code in R (src/main/optim.c), but it hasn't shown me the source of the problem.

Thanks!
Dave

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon 30 Jan 2012 - 22:33:51 GMT

This quarter's messages: by month, or sorted: [ by date ] [ by thread ] [ by subject ] [ by author ]

All messages

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Tue 31 Jan 2012 - 12:30:12 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive