Re: [Rd] configure issue (PR#9379)

From: Kurt Hornik <Kurt.Hornik_at_wu-wien.ac.at>
Date: Thu 23 Nov 2006 - 14:27:48 GMT

>>>>> gml4410 writes:

> Full_Name: Gordon Lack
> Version: 2.4.0
> OS: Redhat Linux AS2.1
> Submission from: (NULL) (198.28.92.5)

> Not sure whether this is a configure issue or an R one.

> It's only a minor issue, so this is really just FYI.

> The code in configure checks for the version of makeinfo by splitting the
> version string into a major and minor component. The tests on these assume they
> are numeric.

> RHAS2.1 shipped with a makeinfo version of "4.0b"

> The result is this:
> =====
> checking whether makeinfo version is at least 4.7...
> ./configure: test: 0b: integer expression expected
> yes
> =====

> ie: an error reported, but the test passed (4.0b > 4.7!!!).

> And there is no command line option to tell configure not to run the
> makeinfo commands (you can set r_cv_prog_makeinfo_v4=0 in your
> environment, but that isn't "right").

Did you try configuring with MAKEINFO=false in your envrionment?

-k



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Nov 24 01:32:45 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Fri 24 Nov 2006 - 05:30:50 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.