Re: [Rd] Problem with tuned Rblas from CRAN with R-2.4.0

From: Daniel Nordlund <res90sx5_at_verizon.net>
Date: Wed 13 Dec 2006 - 17:02:32 GMT


Thanks to Uwe Ligges and Andy Jaworski for their responses. I thought the Rblas I was using was from CRAN master, and I when I encountered the problem originally, I downloaded a new copy from CRAN master. However, I must have misplaced it on download and used an old copy. Long story short, the copy I had was apparently corrupted. I downloaded a new copy from CRAN, and all is functioning. Thanks again for the quick responses.

Dan

Daniel Nordlund
Bothell, WA USA

> -----Original Message-----
> From: Uwe Ligges [mailto:ligges@statistik.uni-dortmund.de]
> Sent: Tuesday, December 12, 2006 11:58 PM
> To: Daniel Nordlund
> Cc: r-devel@stat.math.ethz.ch
> Subject: Re: [Rd] Problem with tuned Rblas from CRAN with R-2.4.0
>
> I just looked into the one for P4 and it does export zdrot_ and works
> for me. Is your one from CRAN master?
>
> Uwe Ligges
>
>
> Daniel Nordlund wrote:
> > I encountered the following problem in R-2.4.0 for Windows binary downloaded
> from CRAN (data from R-help post by Ethan Johnsons). I was also using the
> contributed binary Rblas.dll for Intel P4 chip. The problem doesn't occur with the
> default Rblas.dll.
> >
> >
> > x=c(3.05176E-05, 0.000457764, 0.003204346, 0.0138855, 0.04165649, 0.09164429,
> 0.1527405, 0.1963806, 0.1963806, 0.1527405, 0.09164429, 0.04165649, 0.0138855,
> 0.003204346, 0.000457764, 3.05176E-05)
> > y=c(0.0000306, 0.0004566, 0.0031985, 0.0139083, 0.0415539, 0.0917678, 0.1528134,
> 0.1962831, 0.1962994, 0.1527996, 0.0917336, 0.0415497, 0.0139308, 0.0031917, 0.0004529,
> 0.0000301)
> > fit.lm<-lm(y~x)
> > summary(fit.lm)
> >
> > I got the following popup window error message
> >
> > The procedure entry point zdrot_ could not be found in the dynamic link library
> Rblas.dll
> >
> >
> > After closing the popup, the following was printed in the console:
> >
> > Error in chol2inv(Qr$qr[p1, p1, drop = FALSE]) :
> > lapack routines cannot be loaded
> > In addition: Warning message:
> > unable to load shared library 'C:\R\R-2.4.1beta/modules//lapack.dll':
> > LoadLibrary failure: The specified procedure could not be found.
> >
> > I subsequently downloaded R-2.4.1beta from CRAN and had the same problem with
> the contributed binary Rblas.dll
> >
> >
> > platform i386-pc-mingw32
> > arch i386
> > os mingw32
> > system i386, mingw32
> > status beta
> > major 2
> > minor 4.1
> > year 2006
> > month 12
> > day 07
> > svn rev 40137
> > language R
> > version.string R version 2.4.1 beta (2006-12-07 r40137)
> >
> > OS: WinXP Pro service pack 2
> >
> > I haven't had any problems with the contributed binary up thru R-2.3.1. I checked
> the changes file and saw that for R-2.4.0 the Rblas.dll would have to be recompiled,
> but also that the contributed binaries on CRAN had been updated. However, I
> couldn’t find any Rblas binaries with a date after 2005. Any suggestions on where to
> find an Rblas binary for WinXP and P4 chip, or do I need to try to compile one on my
> own?
> >
> > Thanks for any assistance,
> >
> > Dan
> >
> > Daniel Nordlund
> > Bothell, WA USA
> >
> > ______________________________________________
> > R-devel@r-project.org mailing list
> > https://stat.ethz.ch/mailman/listinfo/r-devel



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Thu Dec 14 17:22:17 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Thu 14 Dec 2006 - 06:30:53 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.