Re: [Rd] fork package problem

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Fri 15 Dec 2006 - 13:39:07 GMT

On 12/15/2006 8:30 AM, billk01 wrote:
> I have been using the fork package on a cluster to spawn jobs. I have
> noticed that I end up with many "R defunct" (zombie) processes following
> the use of fork that do not die completely until I close down R.
> Initially, I thought it may be my code but I ran the example from the
> latest fork package (see code below) on R.2.3.1 and ended up with the
> same problem. The code from the fork package that results in the R
> defunct processes is as follows:
>
> {
> pid = fork(slave=NULL)
> if(pid==0) {
> cat("Hi from the child process\n"); exit()
> } else {
> cat("Hi from the parent process\n");
> }
>
> I am running R-2.3.1 Suse10 linux but the same error also occurs with
> R.2.2.0.
>
> I thought R-dev would be the most useful place but please suggest
> another mailing list if this is in appropriate.

Generally problems with contributed packages should be reported to the maintainer, in this case Greg Warnes. You can get his email address from the DESCRIPTION file in the package, or library(help=fork).

Please also see whether the error occurs in the almost-released 2.4.1, available on CRAN. (This might not be relevant to your problem with fork, but the more testers, the better!)

Duncan Murdoch



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sat Dec 16 12:21:14 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Sat 16 Dec 2006 - 04:31:02 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.