Re: [Rd] Phonetic symbols (IPA) in R graphics

From: Hin-Tak Leung <hin-tak.leung_at_cimr.cam.ac.uk>
Date: Mon 18 Dec 2006 - 13:27:35 GMT

Hi,
I am not familiar with how R deals with postscript fonts, but I am fairly familiar with some font technology, so here are a few random thoughts:
(1) You are not supposed to specify just any random font family string - postscript type 1 fonts contain their own family name inside. (read the top of the font file - the header is is plain ascii). If it works with a random font family name, it is probably because R does not check (?).
(2) if you are using symbol fonts, some of X11 funtionality may depend on your locale - the warning message on PostscriptCIDMetricIndfo did say something about you using a one-byte locale - LANG=en_US.iso88591 . (3) There are various ways to add fonts to the X server - for new linux systems you are just copy them into ${HOME}/.fonts (don't know if R can use fonts via xft), for older linux boxes, you can do "xset fp+ <fontdir>", after running mkfontdir in that directory beforehand.

Giampiero Salvi wrote:
> Hi Paul,
> first thank you for helping out.
>
> On Fri, 15 Dec 2006, Paul Murrell wrote:
>

>> Exactly.  The process would be simpler if you drew directly to
>> PostScript or PDF via postscript() or pdf().
>>
>> Also, the text() call should be ...
>>
>> text(10,10,"whatever",family="ipa")

>
> [...]
>
>> I'm not sure how you got there.  You've specified the family wrong so I
>> would expect more "family not found" warnings.  Let me know if this
>> persists with the correct family specified.

>
> Strangely enough I get the
> "family 'ipa' not included in PostScript device"
> if I run
> text(10,10,"whatever",family="ipa")
> while the "PostScriptCIDMetricInfo" error if I run
> text(10,10,"whatever",family="InternationalPhoneticAlphabet"")
>
> I get the same behaviour when I write directly to the postscript
> device:
>
> postscript(file="whatever.eps")
> plot(10,10,type="n")
> text(10,10,"whatever",family="InternationalPhoneticAlphabet")
> or
> text(10,10,"whatever",family="ipa")
>
> I suspect the "PostScriptCIDMetricInfo" error depends on the fact the
> the encodings/silipa.enc file contains all values from 33 to 255
> (with a few undefines values). Can that be possible?
>
> Thanks,
> Giampiero
>
> ______________________________________________
> R-devel@r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel


R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Tue Dec 19 06:13:19 2006

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 19 Dec 2006 - 16:30:58 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.