Re: [Rd] can't plot a line

From: Marc Schwartz <marc_schwartz_at_comcast.net>
Date: Tue 23 Jan 2007 - 16:02:10 GMT

On Tue, 2007-01-23 at 07:41 -0800, Spencer Graves wrote:
> Consider the following:
>
> plot(0, 0, xlim=c(-10, 10), ylim=c(-50, 50))
> lines(c(0,0), (2*c(-pi, pi))^2)
>
> I see no line in this plot.
>
> R version 2.4.1 (2006-12-18)
> i386-pc-mingw32
>
> locale:
> LC_COLLATE=English_United States.1252;LC_CTYPE=English_United
> States.1252;LC_MONETARY=English_United
> States.1252;LC_NUMERIC=C;LC_TIME=English_United States.1252
>
> attached base packages:
> [1] "stats" "graphics" "grDevices" "utils" "datasets" "methods"
> [7] "base"
>
> My work around is the following:
>
> pi2.2 <- (2*pi)^2
> lines(c(0, 0), c(-pi2.2, pi2.2))
>
> Why won't "lines(c(0,0), (2*c(-pi, pi))^2)" work for me?
> Thanks,
> Spencer Graves

In the first case, you are squaring 2*pi and 2*-pi, both resulting in the same positive number:

> (2*c(-pi, pi))^2

[1] 39.47842 39.47842

You are going from (0,39.47842) to (0,39.47842), hence no line.

HTH, Marc Schwartz



R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed Jan 24 03:16:48 2007

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.1.8, at Tue 23 Jan 2007 - 16:31:12 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.