Re: [Rd] Problem with installing a package for R 2.5.0

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sun, 27 May 2007 17:44:46 -0400

On 27/05/2007 5:40 PM, Recai Yucel wrote:
> Hi All,
>
> I developed a package which did pass all the tests for R 2.4.1. When I
> tried to re-compile it for R 2.5.0 it kept giving me the following message:
>
> *******************
> C:\Program Files\R\R-2.5.0\bin>R CMD install mlmmm_0.1-1.tar.gz
> installing to 'c:/PROGRA~1/R/R-25~1.0/library'
>
>
> ---------- Making package mlmmm ------------
> adding build stamp to DESCRIPTION
> installing NAMESPACE file and metadata
> making DLL ...
> g77 -O3 -Wall -c mlm.f -o mlm.o
> g77 -O3 -Wall -c mlmmm.f -o mlmmm.o
> windres -I c:/PROGRA~1/R/R-25~1.0/include -i mlmmm_res.rc -o mlmmm_res.o
> gcc -shared -s -o mlmmm.dll mlmmm.def mlm.o mlmmm.o mlmmm_res.o
> -Lc:/PROGRA~1
> /R/R-25~1.0/bin -lg2c -lR
> ... DLL made
> installing DLL
> installing R files
> installing inst files
> FIND: Parameter format not correct
> make[2]: *** [c:/PROGRA~1/R/R-25~1.0/library/mlmmm/inst] Error 2
> make[1]: *** [all] Error 2
> make: *** [pkg-mlmmm] Error 2
> *** Installation of mlmmm failed ***

That's a pretty clear sign that your PATH isn't set up correctly: you're using the FIND that comes with Windows rather than the find that comes with the R toolset.

Duncan Murdoch



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sun 27 May 2007 - 21:47:07 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 28 May 2007 - 11:33:41 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.