[Rd] Modules which require gcc4 to build

From: Iain Morrison <idm24_at_medschl.cam.ac.uk>
Date: Fri, 07 Sep 2007 19:31:23 +0100


Dear R-Devel,
  we use R on 32 and 64 bit versions of RHEL AS 4 (U5) where the default compiler is gcc 3. However recently we have had problems updating MCMCpack which appears to require gcc4.

I have a few questions.

  1. Is it OK to mix and match gcc3 and gcc4?
  2. Should we recompile the whole of R under gcc4?
  3. On posting to the RHEL 4 list one respondent said not to touch gcc4 with a barge pole. Is this valid?
  4. What is the safest way to change compiler options for compiling particular R modules.

I have been really impressed with CRAN and the automatic compiling/updating of modules - the only glitch being the occasional failure of compilations that require Tcl/Tk - interactive updating solves this though it is a little annoying. However are more modules going to require gcc4?

thanks

iain

ps I'm a sysadmin rather than a programmer so apologies in advance :->


Iain Morrison
IT Manager
MRC Epidemiology Unit
Institute of Metabolic Science
Box 285
Addenbrooke's Hospital
Hills Road
Cambridge
CB2 0QQ

Tel 01223 769200



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sat 08 Sep 2007 - 13:59:54 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sat 08 Sep 2007 - 14:40:34 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.