Re: [Rd] installing packages (PR#9907)

From: Peter Dalgaard <p.dalgaard_at_biostat.ku.dk>
Date: Wed, 12 Sep 2007 22:50:16 +0200

alexander.jerneck_at_gmail.com wrote:
> Full_Name: Alexander Jerneck
> Version: 2.4.0 (2006-10-03)
> OS: Gentoo (2.6.17-custom kernel)
> Submission from: (NULL) (130.91.92.78)
>
>
> I had trouble installing R packages, either from inside R or from the
> commandline, with R complaining about not finding /usr/bin/pwd
> I have pwd in /bin/ so I created a symlink from /usr/bin/pwd to /bin/pwd and now
> I can install packages. I do not know where the original problem is however.
>
Please don't report it as a bug then! Or at least do more of your homework first.

As far as I can see, this is handled by the configure script which goes looking for pwd and records the result in $GETWD (in Makeconf and the INSTALL and REMOVE scripts). If you compile on one system and run on another, strange things can and will happen if they do not have things in the same places. There are a few other places where pwd is called directly (texi2dvi and libtool) but I don't think that can give the error message you describe.

-- 
   O__  ---- Peter Dalgaard             ุster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark          Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard_at_biostat.ku.dk)                  FAX: (+45) 35327907

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed 12 Sep 2007 - 20:53:52 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 13 Sep 2007 - 12:40:45 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.