[R] help and Firefox

From: Erich Neuwirth <erich.neuwirth_at_univie.ac.at>
Date: Wed, 15 Aug 2007 12:23:39 +0200


My configuration is Windows XP, R-2.5.1patched. My standard browser in Windows is Firefox 2.0.6, and I am using htmlhelp.
I have problems with starting the browser for displaying help. help("lm") works as it should when Firefox is already running. When I do help("lm") and the browser is not yet started, I get
Error in shell.exec(url) :
'C:\PROGRA~2\R\R-25~1.1\library\stats\html\lm.html' not found but nevertheless the browser starts and the html file is displayed some seconds later.

If I try to use help from within a function and the browser is not open, the browser will not start and therefore help will not be displayed.

Has anybody else experienced the same problem? Is there a solution?

-- 
Erich Neuwirth, University of Vienna
Faculty of Computer Science
Computer Supported Didactics Working Group
Visit our SunSITE at http://sunsite.univie.ac.at
Phone: +43-1-4277-39464 Fax: +43-1-4277-39459

______________________________________________
R-help_at_stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-help
PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
and provide commented, minimal, self-contained, reproducible code.
Received on Wed 15 Aug 2007 - 10:34:17 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 15 Aug 2007 - 20:35:11 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-help. Please read the posting guide before posting to the list.