[Rd] savePlot bug in R 2.6.0? (PR#10420)

From: <lupi_at_unimol.it>
Date: Sun, 11 Nov 2007 18:50:05 +0100 (CET)


Full_Name: Claudio Lupi
Version: 2.6.0
OS: Windows XP
Submission from: (NULL) (85.18.14.35)

Try the following:

xy <- matrix(rnorm(20),10,2)
plot(xy)
savePlot("c:/xy", type="pdf")
savePlot("c:/xy", type="eps")

This used to work fine with previous R versions. Instead, with R 2.6.0 I get:

> xy <- matrix(rnorm(20),10,2)
> plot(xy)
> savePlot("c:/xy", type="pdf")

Error in savePlot("c:/xy", type = "pdf") : Invalid font type In addition: Warning messages:
1: In savePlot("c:/xy", type = "pdf") :
  font family not found in PostScript font database 2: In savePlot("c:/xy", type = "pdf") :
  font family not found in PostScript font database
> savePlot("c:/xy", type="eps")

Error in savePlot("c:/xy", type = "eps") : Invalid font type In addition: Warning messages:
1: In savePlot("c:/xy", type = "eps") :
  font family not found in PostScript font database 2: In savePlot("c:/xy", type = "eps") :
  font family not found in PostScript font database
>

savePlot works fine with type = "bmp".



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Mon 12 Nov 2007 - 07:59:44 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 12 Nov 2007 - 11:30:16 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.