Re: [Rd] [Bioc-devel] EBImage: Devel version on Windows not building

From: Michael Lawrence <mflawren_at_fhcrc.org>
Date: Wed, 13 Aug 2008 09:21:55 -0700

On Wed, Aug 13, 2008 at 6:56 AM, Laurent Gautier <lgautier_at_gmail.com> wrote:

> There is a chance that further changes in the handling of plotting
> devices event appear;
> I think that there is an ongoing effort to bring new features for R-2.8.
>
> What about bumping that to r-devel ? (Sorry if you already did and I missed
> it).
> The solution you came up with could be of general use, and could
> somehow be included into R-devel
> (either as functions, macros, or as instructions in R-exts).
>

Well a better solution would be an abstraction around the event loop handling, so that package code is the same across platforms. I understand that's a non-trivial task.

Michael

>
>
> L.
>
>
>
> 2008/8/13 Michael Lawrence <mflawren_at_fhcrc.org>:
> > This is almost certainly due to the lack of tcl_do in R devel. I fixed
> this
> > in RGtk2 by using multiple threads and synchronizing on the Windows event
> > loop. If the maintainer wants an example of how to do this, he can check
> out
> > RGtk2. I will upload the new version to CRAN today.
> >
> > Michael
> >
> > On Tue, Aug 12, 2008 at 6:31 PM, Henrik Bengtsson <hb_at_stat.berkeley.edu
> >wrote:
> >
> >> Hi,
> >>
> >> thanks for fixing the DESCRIPTION file for EBImage. FYI, the Windows
> >> version does not build:
> >>
> >> * creating vignettes ... ERROR
> >> Error in inDL(x, as.logical(local), as.logical(now), ...) :
> >> unable to load shared library
> >>
> 'D:/biocbld/bbs-2.3-bioc/tmpdir/Rinst415629052/EBImage/libs/EBImage.dll':
> >> LoadLibrary failure: The specified procedure could not be found.
> >>
> >> Error: processing vignette 'AnalysisWithEBImage.Rnw' failed with
> >> diagnostics:
> >> chunk 1 (label=loadlib)
> >> Error : package/namespace load failed for 'EBImage'
> >> Execution halted
> >>
> >> More:
> >>
> http://bioconductor.org/checkResults/2.3/bioc-LATEST/EBImage/gewurz-buildsrc.html
> >>
> >> I noticed this already a few weeks ago (before the typo in DESCRIPTION
> >> was added) and hoped it would solve "itself", but it is still there.
> >> Not sure if it is an EBImage or a BioC server config problem.
> >>
> >> Cheers
> >>
> >> Henrik
> >>
> >> PS. I can solve all these problems for myself, but I reporting it for
> >> the sake of automatic installation etc. DS.
> >>
> >> _______________________________________________
> >> Bioc-devel_at_stat.math.ethz.ch mailing list
> >> https://stat.ethz.ch/mailman/listinfo/bioc-devel
> >>
> >
> > [[alternative HTML version deleted]]
> >
> > _______________________________________________
> > Bioc-devel_at_stat.math.ethz.ch mailing list
> > https://stat.ethz.ch/mailman/listinfo/bioc-devel
> >
>

        [[alternative HTML version deleted]]



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Wed 13 Aug 2008 - 16:25:42 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Wed 13 Aug 2008 - 16:36:32 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive