Re: [Rd] R-beta does not install on FreeBSD

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Sun, 17 Aug 2008 13:02:09 +0100 (BST)

Can you track down which Makefile this is and what line 28 is?

My guess is that your make does not like the comment character at line 24 in po/Makefile.in.in, in which case please delete the line.

But the BSD-like makes on Solaris and MacOS have no problem with it.

On Sun, 17 Aug 2008, Rainer Hurling wrote:

> I am trying to install R-beta_2008-08-16_r46368.tar.gz on FreeBSD 8.0-CURRENT
> (i386). The code stops compiling with the following message:
>
>
> --------------------------------------------------------------------
> [.. snip ..]
> building package 'tcltk'
> mkdir ../../../library/tcltk
> mkdir ../../../library/tcltk/R
> mkdir ../../../library/tcltk/demo
> mkdir ../../../library/tcltk/exec
> mkdir ../../../library/tcltk/po
> mkdir ../../../library/tcltk/man
> making init.d from init.c
> making tcltk.d from tcltk.c
> making tcltk_unix.d from tcltk_unix.c
> `Makedeps' is up to date.
> gcc -std=gnu99 -I../../../../include -I/usr/local/include/tcl8.4
> -I/usr/local/include/tk8.4 -I/usr/local/include -I/usr/local/include -fpic
> -g -O2 -c init.c -o init.o
> gcc -std=gnu99 -I../../../../include -I/usr/local/include/tcl8.4
> -I/usr/local/include/tk8.4 -I/usr/local/include -I/usr/local/include -fpic
> -g -O2 -c tcltk.c -o tcltk.o
> gcc -std=gnu99 -I../../../../include -I/usr/local/include/tcl8.4
> -I/usr/local/include/tk8.4 -I/usr/local/include -I/usr/local/include -fpic
> -g -O2 -c tcltk_unix.c -o tcltk_unix.o
> gcc -std=gnu99 -shared -L/usr/local/lib -o tcltk.so init.o tcltk.o
> tcltk_unix.o -L/usr/local/lib -ltcl84 -L/usr/local/lib -ltk84
> -L/usr/local/lib -lX11 -lm
> mkdir ../../../../library/tcltk/libs
> installing parsed NAMESPACE files
> "Makefile", line 28: Need an operator
> make: fatal errors encountered -- cannot continue
> *** Error code 1
>
> Stop in /usr/local/R-beta.
> --------------------------------------------------------------------
>
>
> This happens with all recent beta versions. R version 2.7.1 Patched
> (2008-08-10 r46284) installed and worked fine.
>
> Could this be a bug with R-beta or is there something wrong with my FreeBSD
> version?
>
> Any help is appreciated.
>
> Thanks in advance,
> Rainer Hurling
>
> ______________________________________________
> R-devel_at_r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

-- 
Brian D. Ripley,                  ripley_at_stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Sun 17 Aug 2008 - 12:04:23 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Sun 17 Aug 2008 - 16:36:58 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive