[Rd] problem running dll in R

From: rcoder <mpdotbook_at_gmail.com>
Date: Sat, 23 Aug 2008 17:44:38 -0700 (PDT)

Hi everyone,

I've created a dll for a fortran subroutine, and when I call the subroutine in R (via a wrapped function) a standard program shutdown windows error prompt immediately pops up: the program has encountered a problem and needs to be shut down... send message / don't send message to MS... etc.

When I click "Don't send", the R consol does not then shut down, and appears to continue to execute, and task manager does not indicate "not responding". The problem is the execution takes too long, and I think the program is just hanging rather than executing. I have tested with different fortran code, and the same thing happens, so I don't think it is anything to do with that side of things.

I created fortran code in a text editor, compiled using Plato3 IDE, then converted the file into a dll using gFortran. I place the dll in the R directory and it load in the console. The problem seems to occur when defining the data types in R, for the variables in the fortran routine.

I was just wondering if anyone has experienced anything similar when trying to call fortran subroutines in R?

Thanks,

rcoder

-- 
View this message in context: http://www.nabble.com/problem-running-dll-in-R-tp19126733p19126733.html
Sent from the R devel mailing list archive at Nabble.com.

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Mon 25 Aug 2008 - 06:55:32 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Mon 25 Aug 2008 - 12:37:28 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive