Re: [Rd] small bug in plot.rpart?

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Wed, 15 Oct 2008 20:46:02 +0100 (BST)

>From the posting guide:

   For questions about unexpected behavior or a possible bug, you should,    at a minimum, copy and paste the output from sessionInfo() into your    message.

(This would have told us the rpart version number.)

   When mentioning version numbers, always use the full version number,    e.g., `2.6.1', not just `2.6', and also mention the platform    (Windows2000, Linux, MacOS X, with their versions).

   If the question relates to a contributed package , e.g., one downloaded    from CRAN, try contacting the package maintainer first.

(rpart is a contributed package: see library(help="rpart").)

And from the FAQ:

   Bug reports on contributed packages should be sent first to the    package maintainer, and only submitted to the R-bugs repository by    package maintainers, mentioning the package in the subject line.

As the rpart maintainer I can tell you that this will be changed to use dev.new() in the next release, but the current release (3.1-41) is over 6 months' old and predates development of 2.8.0.

On Wed, 15 Oct 2008, apjaworski_at_mmm.com wrote:

> Hi,
>
> This happens in 2.8 and 2.9. I am posting this here because I am not sure
> if one should use bug.report for reporting bugs in unreleased versions.
>
> I was trying to run the example from the help page of plot.rpart. I got
>
>> library(rpart)
>> fit <- rpart(Price ~ Mileage + Type + Country, cu.summary)
>> plot(fit, compress=TRUE)
> Error in get(getOption("device")) : invalid first argument
>
> This also produces a blank graphics window. When I run the plot command
> again everything seems to work fine, so the error only occurs when the
> graphics window is not open.
>
> I use Windows XP SP2. I just compiled the newest RC of 2.8 (R version
> 2.8.0 RC (2008-10-14 r46714)). I ran "make fullcheck" on it and
> everything checked out fine.
>
> The same thing happens in 2.9 but it worked fine in 2.7.2.
>
> Andy
>
>
> __________________________________
> Andy Jaworski
> 518-1-01
> Process Laboratory
> 3M Corporate Research Laboratory
> -----
> E-mail: apjaworski_at_mmm.com
> Tel: (651) 733-6092
> Fax: (651) 736-3122
> [[alternative HTML version deleted]]
>
> ______________________________________________
> R-devel_at_r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel
>

-- 
Brian D. Ripley,                  ripley_at_stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel
Received on Wed 15 Oct 2008 - 19:48:48 GMT

Archive maintained by Robert King, hosted by the discipline of statistics at the University of Newcastle, Australia.
Archive generated by hypermail 2.2.0, at Thu 16 Oct 2008 - 09:30:22 GMT.

Mailing list information is available at https://stat.ethz.ch/mailman/listinfo/r-devel. Please read the posting guide before posting to the list.

list of date sections of archive