Re: [Rd] Small patch to packages.R

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sat, 07 Nov 2009 09:47:18 -0500

On 06/11/2009 9:49 AM, Chris Masters wrote:
> Very small patch to packages.R
>
> install.packages on an internal package repository that worked with 2.9
> failed in 2.10
>
> Problem:

>> available.packages(contriburl="http://url.to.my/repo")

> Error in f(res) : invalid subscript type 'list'
>
> This occurred because the PACKAGES file had no dependency on R in the
> Depends field on any of the packages. Got around it by adding "Depends: R
> (>=2.7.0)" to the packages but it was still a regression from 2.9 behaviour.

Thanks. We already had a patch under way for this one, but it hadn't made it into the code yet. (See the thread "Re: [Rd] error in install.packages() (PR#14042)".) It has also led to some discussion of changes to sapply, but those will be for 2.11.0, not R-patched.

Duncan



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sat 07 Nov 2009 - 14:50:37 GMT

This archive was generated by hypermail 2.2.0 : Sat 07 Nov 2009 - 15:00:21 GMT