Re: [Rd] error message when running news()

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: Sun, 22 Nov 2009 09:13:09 -0500

On 22/11/2009 7:34 AM, Gabor Grothendieck wrote:
> When running news() in I get this error message from print.news_db:
>

>> news()

> Error: invalid version specification 2.0.12.0.1 patched2.1.02.1.12.1.1
> patched2.10.02.10.0 patched2.2.02.2.12.2.1 patched2.3.02.3.12.3.1
> patched2.4.02.4.12.4.1 patched2.5.02.5.12.5.1
> patched2.6.02.6.12.6.22.6.2 patched2.7.02.7.12.7.22.7.2
> patched2.8.02.8.12.8.1 patched2.9.02.9.12.9.22.9.2 patched
>> R.version.string
> [1] "R version 2.10.0 Patched (2009-11-21 r50532)"

This is also present in R-devel. It's an error in utils:::print.news_db.

The problem is that versions like "2.0.1 patched" can't be converted to numeric versions, but print.news_db tries to do it to sort the entries.   The repetitive message is just a bad error message from .make_numeric_version.

Presumably the intention is that "2.0.1 patched" should compare bigger than "2.0.1" and less than "2.0.2", but I don't know the best fix for this.

Duncan Murdoch



R-devel_at_r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Sun 22 Nov 2009 - 14:16:55 GMT

This archive was generated by hypermail 2.2.0 : Sun 22 Nov 2009 - 16:30:34 GMT