Re: R-beta: R 0.50 alpha

Kurt Hornik (Kurt.Hornik@ci.tuwien.ac.at)
Tue, 29 Jul 1997 14:04:56 +0200


Date: Tue, 29 Jul 1997 14:04:56 +0200
Message-Id: <199707291204.OAA19241@aragorn.ci.tuwien.ac.at>
From: Kurt Hornik <Kurt.Hornik@ci.tuwien.ac.at>
To: "Ennapadam Venkatraman" <VENKAT@biosta.mskcc.org>
Subject: Re: R-beta: R 0.50 alpha
In-Reply-To: <199707251602.SAA13750@hypatia.math.ethz.ch>

>>>>> Ennapadam Venkatraman writes:

> The new code seems to have broken various things.
> Autoloading of libraries doesn't seem to work: 

>> library(survival4)
>    Autoloading required library: splines
>    Error in pos.to.env(pos) : invalid "pos" argument
>> search()
>    [1] ".GlobalEnv"        "library:survival4" "library:date"
>    [4] "library:base"

> The coxph function the the library survival4 doesn't seem to work. It
> just crashes R. See the example below:

> ...

This is a combination of an old version of survival4 (which in
particular contained an old version of require()) and the new version of
R.

For some reason, the current version of survival4 did not make it into
CRAN thus far ... sorry.  I have just placed the current versions into
the CRAN master `src/contrib' dir, they should be available at the
mirror sites within 24 hours.

To avoid similar problems in the future, the package developers are
gradually shifting to adding version numbers to their packages.  The
current version of survival4 is

	survival-4R0.1.tar.gz

(S version 4, R port version 0.1).

-kh
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=