R-beta: R and funfits

John Logsdon (j.logsdon@lancaster.ac.uk)
Thu, 7 Aug 1997 01:30:30 +0100 (BST)


Date: Thu, 7 Aug 1997 01:30:30 +0100 (BST)
From: John Logsdon <j.logsdon@lancaster.ac.uk>
To: r-help@stat.math.ethz.ch
Subject: R-beta: R and funfits 
In-Reply-To: <Pine.SUN.3.95.970806111853.2623C-100000@zen>

Further to my message ...

Firstly for some reason (possibly the time of day) x11 now appears to work
OK with R0.50a1.  I did try it lower case but some funny stuff was
possibly lying around in the workspace (apologies for the 1960s
programming terminology).

Anyway, back to funfits.

Previously, even on startup, if I loaded the .RData file, the graphics
wouldn't work.  The possible key was that there is a plot.window function
in funfits which is also of course a plotting primitive.  So I checked in
all the fortran code (which could have passed the name back), found
nothing and trusted the authors not to have used nasty fortran 66 r*4's
for characters, and changed the S-code to grot.window etc. 

I also tidied up the fortran and hey presto the graphics now appears to
work when the funfits objects are loaded.  However NAs are not allowed in
xlim in plot.window so there is still a problem.  Also there is no maps
library and I couldn't find the thin plate surface fitting routine tps for
some reason.

The story goes on but the problem does not appear to be as fundamental as
I  thought it was.  Welcome to hacker's heaven.

John

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=