Re: R-beta: Survival 4

Kurt Hornik (Kurt.Hornik@ci.tuwien.ac.at)
Wed, 24 Sep 1997 16:11:29 +0200


Date: Wed, 24 Sep 1997 16:11:29 +0200
Message-Id: <199709241411.QAA14201@aragorn.ci.tuwien.ac.at>
From: Kurt Hornik <Kurt.Hornik@ci.tuwien.ac.at>
To: "Ennapadam Venkatraman" <VENKAT@biosta.mskcc.org>
Subject: Re: R-beta: Survival 4
In-Reply-To: <199709231951.VAA14118@hypatia.math.ethz.ch>

>>>>> Ennapadam Venkatraman writes:

> I installed the latest version of R (Version 0.50 Alpha-4) and it breaks 
> survival4 as follows (it worked fine under Version 0.50 Alpha-3)

R> library(survival4)
> Autoloading required library: splines 
R> survfit(Surv(runif(25),rbinom(25,1,0.4)) ~ 1)
> Error in eval(frame, data)[subset, , drop = FALSE] : incorrect number of
> dimensions

It seems that the latest released version of survival4 (which as far as
I know is not meant to be used with the `final' 0.50 which will in fact
be a 0.60, hopefully soon) has versions of model.frame and
model.frame.default which break things.

For me (note under the current development snapshot, so maybe not under
0.50-a4) it works to do
	rm(model.frame, pos = N)
	rm(model.frame.default, pos = N)
where N is the position of the survival4 package in the search list.

-k
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=