R-beta: $PERL in configure

Gordon Maclean (maclean@stout.atd.ucar.edu)
Tue, 10 Feb 1998 17:52:44 GMT


From: maclean@stout.atd.ucar.edu (Gordon Maclean)
Date: Tue, 10 Feb 1998 17:52:44 GMT
Message-Id: <199802101752.RAA04692@ripple.atd.ucar.edu>
To: R-help@stat.math.ethz.ch
Subject: R-beta: $PERL in configure

Content-MD5: WUiME0ZXsf2Z8XWJ/Kj8ZQ==
Sender: owner-r-help@stat.math.ethz.ch
Precedence: bulk


One minor request, on the subject of installation scripts.
Could you change "configure" to use the value of $PERL,
when it checks for the version number? =20

  PERL_VERSION_NUMBER=3D`$PERL -v | sed -n 's/^.*perl.*version =
\(.\).*/\1/p'
  =04
rather than:

  PERL_VERSION_NUMBER=3D`perl -v | sed -n 's/^.*perl.*version =
\(.\).*/\1/p'`


On our systems, plain perl is version 4, and we must set PERL to "perl5"
in config.site. Then the above version check fails to detect version 5.

I believe that the value of $PERL is otherwise propagated to the build =
scripts.

Thanks,

Gordon



=20
-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._