Having some difficulty with PSfrag 3.03 (need some advice)

Dimitri J. Kirill (djk588@rookery.acns.nwu.edu)
Tue, 17 Mar 1998 12:44:09 -0600 (CST)


Date: Tue, 17 Mar 1998 12:44:09 -0600 (CST)
From: "Dimitri J. Kirill" <djk588@rookery.acns.nwu.edu>
To: psfrag@rascals.Stanford.EDU
Subject: Having some difficulty with PSfrag 3.03 (need some advice)

Excuse me if I'm bothering you, but...

I'm having some difficulties with PSfrag 3.03.


If one reads the documentation for PSfrag 3.0 (downloaded from CTAN), it says
that you need to have a version of LaTeX2e *on or after* 12/95, otherwise it
might not work properly. Well, sure enough, I tried a simple test, and when
I converted the dvi file to PS (using dvips) and viewed it with ghostview, 
the ghostview program could not display it.

Below is my little test document:


\documentclass[12pt]{article}
\usepackage{psfrag}
\usepackage{graphicx}

\begin{document}

\psfrag{tg}{$e^{i\pi}=-1$}

\includegraphics{eulerport.eps}
% eulerport.eps is a very simple xfig-generated file containing 
%  "tg" as a tag

\end{document}


That's it! I have the psfrag.pro and psfrag.sty in the same subdirectory
as the test file.

Now, to be honest, I did encounter a slight problem when I LaTeXed the
psfrag.ins file at the very beginning (an error message, which I carriage-
returned). Also, I did receive a warning message from the LaTeX
program as it was compiling my test document.  
FYI, I am using a version of LaTeX2e
released 6/95 (6 months short!).

Do you have any suggestions for me? Should I try to get a hold
of an older version of PSfrag (say, ver. 2, for example) which might be
compatible with my older LaTeX2e, or is there a quick fix? I'd
really like to avoid upgrading my version of LaTeX2e, if I can help it...


Thank you for your time.