Re: R-beta: Not loading C library

ernst.molitor@uni-bonn.de
Mon, 30 Mar 1998 20:44:19 GMT


Date: Mon, 30 Mar 1998 20:44:19 GMT
Message-Id: <199803302044.UAA10773@ernst.molitor>
To: mkiefte@gpu.srv.ualberta.ca
Subject: Re: R-beta: Not loading C library
From: ernst.molitor@uni-bonn.de

Dear Michael Kiefte, 

as a happy (very new) user of R (thanks to everyone involved in
writing this fine package- it's great!), all I could find out was that
with the latest (?) _alpha_ version, for reasons unintelligible to me
(sorry), the .../R-snapshot/library/class/R/class file lacks a line
like

    library.dynam("class.so")

at its very end. With this line included, the test.R from the class
package works like a charm on my ELF Linux-2.0.91/GLIBC-2.1x box;
otherwise, I see the error message you have described. Obviously, this
is not a topic for the R-_beta_ discussion list, forgive me for having
mentioned it here...

In R-0.61.2 (compiled out of the box, that is, from the gzipped tar
file), the last line of the R code for the class package in
..../R-0.61.2/library/class/R/class is

    library.dynam("class", package = "class")

For this version, the test.R file produces a nice graphical
output without any changes...

Best regards, 

Ernst

---
ernst.molitor@uni-bonn.de
Institute for Medical Microbiology and Immunology
University of Bonn, FRG
-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._