R-beta: matrix multiplication not Fortran

Jim Lindsey (jlindsey@luc.ac.be)
Mon, 6 Apr 1998 09:00:28 +0200 (MET DST)


From: Jim Lindsey <jlindsey@luc.ac.be>
Message-Id: <9804060700.AA25608@alpha.luc.ac.be>
Subject: R-beta: matrix multiplication not Fortran
To: r-help@stat.math.ethz.ch (r-help)
Date: Mon, 6 Apr 1998 09:00:28 +0200 (MET DST)

1. Sorry but I was a bit hasty about the reason for crashes on Friday
(upgrading Linux is always an experience, especially with the
bugginess of all Redhat versions ...)
  In fact, my library functions calling Fortran all happen to use the
%o% operator as well whereas the C ones that I tried do not. The
problem is multiplication of 1x1 matrices not Fortran.
Try 1%o%1 or
y <- matrix(1)
y*y
Both crash R61.2 on Redhat 5 but not R61.1. However they do not
crash my son Patrick's R61.2 on an Amiga with Linux. (His HP portable
has been sent back 4 times under guarantee in the last two months. HP
guarantees are not worth the ink they are printed with!)

2. A second problem with Redhat 5: ctrl-C does not work (same as with
Redhat 4.1). This time, it apparently is not the readline library. I
compiled without it and the problem persists: one ctrl-C and then it
no longer works. Has anyone any idea what library has the bug? Thanks.
Jim
-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._