R-beta: fortran problems with 0.62

Mike Meyer (mikem@stat.cmu.edu)
Mon, 15 Jun 1998 10:40:00 -0400


Message-Id: <199806151440.KAA14858@desire.stat.cmu.edu>
To: r-help@stat.math.ethz.ch
Subject: R-beta: fortran problems with 0.62
Date: Mon, 15 Jun 1998 10:40:00 -0400
From: Mike Meyer <mikem@stat.cmu.edu>

One of the big problems in mixing fortran and C is knowing if the various 
compilers/loaders need extra underscores in the names of the entry points.

The 0.62 release of R, which has reverted to using fortran,  seems to be 
broken in this respect.

In particular, on a machine which does not append underscores to fortran entry 
points (HP-UX 10.20), there are many problems.

It seems that the configure script correctly determines is an extra underscore 
is needed or not, but it also seems that this information is not used.

Early in the make process, the GETSYMBOLS script is run, but as far as I can 
tell this adds an extra underscore all the time.  The GETSYMBOLS script relies 
on the information in appl/ROUTINES to determine if an entry point is fortran 
or C.  However some of those entries (e.g., bkslv) are listed as fortran when 
they are really C entry points that have previously been converted from 
fortran (using f2c).

Suffice to say, one (at least this "one") gets lost in the process of adding, 
subtracting underscores from various tables.

Has anyone already fixed the underscore mess?

Regards, --Mike


Mike Meyer, Department of Statistics, Carnegie Mellon University


-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._