Re: R-beta: netscape/R interaction

Hedderik van Rijn (rijn@swi.psy.uva.nl)
Thu, 18 Jun 1998 21:03:05 +0200 (CEST)


From: Hedderik van Rijn <rijn@swi.psy.uva.nl>
Date: Thu, 18 Jun 1998 21:03:05 +0200 (CEST)
To: gordon.harrington@uni.edu
Subject: Re: R-beta: netscape/R interaction
In-Reply-To: <ML-3.3.898191935.6838.gordon@localhost>
Message-Id: <Pine.LNX.3.96.980618205135.788P-100000@swipc30.swi.psy.uva.nl>

Hi,

> Using netscape 4.03 (or 2.x or 3.x)/ R-0.62.1 with SPARC Solaris 2.4:
> when netscape is running for help, graphics in R quit with "Color allocation
> error". 

I'm not familiar with this specific configuration, but often the problem is:

Netscape allocates a lot of colors by default which then can't be used by
other programs. So after Netscape has "occupied" most of your colormap,
other programs often cannot find enough colors to be able to work with. This
is not a specific Netscape problem, although netscape could behave somewhat
better.

> Any suggestions?

4, in the order I would try them:

1. Try to find a 16bit colordepth monitor :-)
2. Start R first, then Netscape (Netscape *can* behave itself...)
3. Start Netscape using the command line option "-install". It then installs
   a private colormap. This will make your screen "flash" each time you
   switch windows, but probably will solve your problem.
4. Start Netscape using the command line option "-mono". Away are your
   problems... and your colors in Netscape. :-)

Good luck,
  Hedderik.

---
http://www.swi.psy.uva.nl/usr/rijn or ICQ: 13506689

-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._