R-beta: INSTALL

Jim Lindsey (jlindsey@luc.ac.be)
Fri, 19 Jun 1998 12:29:20 +0200 (MET DST)


From: Jim Lindsey <jlindsey@luc.ac.be>
Message-Id: <9806191029.AA03780@alpha.luc.ac.be>
Subject: R-beta: INSTALL
To: r-help@stat.math.ethz.ch (r-help)
Date: Fri, 19 Jun 1998 12:29:20 +0200 (MET DST)

  Yesterday, I corrected the bug in summary (for residuals) that I
reported and then reinstalled base (in the same way I install my
libraries). Later, when I went to use a library, what was my
astonishment to see a message that library was not yet implemented.
I eventually figured out that you have to do the make of all of R to
get base installed correctly (it of course skips what is already
made) and not R INSTALL it in the src/library directory.
  This brings up a second problem. Reinstalling base still erases my
(presonal) global Rprofile, something that I thought was supposed to
be fixed in 62.
  It would also be nice if the proper options were given to mkdir for
installing libraries: every time a library is reinstalled (debugging),
mkdir now complains (twice) that it cannot create the directories
because they already exist.
  The standard f77 shell for f2c complains about the option -fpic but
works nonetheless.
  In the original compile of R62.1, saw the message saying that I
should go on to make the docs, or at least help. But then it when on
and did them without asking. I only want the mininal help on my
portable so this is annoying.
  Jim
-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-.-
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request@stat.math.ethz.ch
_._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._