R-alpha: Image: Graphics on X11: color allocation error

Kurt Hornik (Kurt.Hornik@ci.tuwien.ac.at)
Mon, 2 Dec 1996 17:55:26 +0100


Date: Mon, 2 Dec 1996 17:55:26 +0100
Message-Id: <199612021655.RAA15544@aragorn.ci.tuwien.ac.at>
From: Kurt Hornik <Kurt.Hornik@ci.tuwien.ac.at>
To: Martin Maechler <maechler@stat.math.ethz.ch>
Subject: R-alpha: Image: Graphics on X11:	color allocation error
In-Reply-To: <9612021330.AA07500@>

>>>>> On Mon, 2 Dec 96 14:30:38 +0100,
>>>>> Martin Maechler <maechler@stat.math.ethz.ch> said:

> Try the following
>> source(system.file("demos/graphics", "image"))

> The first  (greenish) is drawn nicely,
> during the drawing of the 2nd image, I get :

> Error: color allocation error
> -----------------------------

> Somehow  R should be more 'bossy' about re-allocating colors
> (other X11 utilities do this also...)

> It is on an Sparc 5, using the standard (8-bit color) 'framebuffer'
>  (``graphic card'') called "cgsix".

Here's what happens on my Linux-elf:

with Netscape open, the error occurred immediately.

After quitting Netscape, the demo works beautifully, but Netscape won't
start again ...

of course, after dev.off() it starts ...

-k
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
r-testers mailing list -- For info or help, send "info" or "help",
To [un]subscribe, send "[un]subscribe"
(in the "body", not the subject !)  To: r-testers-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-