R-alpha: R16 problems

Jim Lindsey (jlindsey@luc.ac.be)
Tue, 11 Feb 1997 09:04:46 +0100 (MET)


From: Jim Lindsey <jlindsey@luc.ac.be>
Message-Id: <9702110804.AA20113@alpha.luc.ac.be>
Subject: R-alpha: R16 problems
To: r-testers@stat.math.ethz.ch (r-testers)
Date: Tue, 11 Feb 1997 09:04:46 +0100 (MET)

1. The bugfix for R16 contains three files, but nextmethod has size 0.
Hence what follows does not have the complete update to R16.1 (I
assume).

2. colours are missing from Rprofile. When I copy the code from R15,
it does not work.

3. suppose x and y are numeric and gp is a factor variable. Construct
a data.frame:
z <- data.frame(y,gp,x)
attach(z)
model.matrix(y~x+gp,data=z)
This gives a matrix with columns
(Intercept) x2 x3 x4 gp
The order in the formula and in the data.frame get all mixed up. lm
and glm do not use this sort of thing, but apparently a lot of S
functions do.

4. If gee is used with clusters of size 3, it cannot print the
correlation matrix but says subscript out of bounds. However, the
first time I tried it, it gave a segmentation fault so there appears
to be something wrong with subscript bound checking.

Any of these problems may have been in previous versions.
Jim
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
r-testers mailing list -- For info or help, send "info" or "help",
To [un]subscribe, send "[un]subscribe"
(in the "body", not the subject !)  To: r-testers-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-