R-alpha: par(lwd)

Thomas Lumley (thomas@biostat.washington.edu)
Tue, 18 Feb 1997 18:10:32 -0800 (PST)


Date: Tue, 18 Feb 1997 18:10:32 -0800 (PST)
From: Thomas Lumley <thomas@biostat.washington.edu>
To: r-testers@stat.math.ethz.ch
Subject: R-alpha: par(lwd)
In-Reply-To: <199702181910.IAA23421@stat1.stat.auckland.ac.nz>


The initial value for par("lwd") is zero, but par(lwd) will not accept 
this value.  This seems to be responsible for an error in some plotting 
examples that I haven't been able to pin down very well. 

The solution is to add par(lwd=1) to your .Rprofile

Solaris-gorn% ~/R16

R : Copyright 1997, Robert Gentleman and Ross Ihaka
Version 0.16.1  (Released: February 11, 1997)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type "license()" for details.

> par("lwd")
[1] 0
> par(lwd=0)
Error: attempt to set invalid value for graphics parameter "lwd".
> par(lwd=1)
> 


Thomas Lumley
-----------------------------------------------------+------
Biosadistics		: "Never attribute to malice what  :
Uni of Washington	:  can be adequately explained by  :
Box 357232		:  incompetence" - Hanlon's Razor  :
Seattle WA 98195-7232	:				   :
------------------------------------------------------------

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
r-testers mailing list -- For info or help, send "info" or "help",
To [un]subscribe, send "[un]subscribe"
(in the "body", not the subject !)  To: r-testers-request@stat.math.ethz.ch
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-