Re: [Rd] libz>=1.2.1 requirement - necessary?

From: Prof Brian Ripley <ripley_at_stats.ox.ac.uk>
Date: Tue 27 Jul 2004 - 05:40:02 EST


There are some slight interface differences in the gzfile code, so 1.2.1 is needed. However, we have since found a bug in that which affects R, so please use the bundled code.

The circumstances of both are rather rare, and valgrind was needed to show the second (a use of an unitialized variable that sometimes bit us).

On Tue, 20 Jul 2004, Simon Urbanek wrote:

> I the course of cleaning up the build for OS X I wondered why R
> requires zlib 1.2.1+. Is there any specific reason for that? OS X comes
> with zlib 1.1.4, so I wonder if using the system library has any
> drawbacks... (it worked for me, but..). I found nothing in the
> archives, but maybe someone remembers?

-- 
Brian D. Ripley,                  ripley@stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://www.stat.math.ethz.ch/mailman/listinfo/r-devel
Received on Tue Jul 27 05:57:19 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:03 EST