Re: [Rd] (PR#7163) Install packages does not work on Win2003 serv er

From: Uwe Ligges <ligges_at_statistik.uni-dortmund.de>
Date: Fri 13 Aug 2004 - 16:55:30 EST

Walke, Rainer wrote:

> 

>>-----Original Message-----
>>From: Uwe Ligges [SMTP:ligges@statistik.uni-dortmund.de]
>>Sent: Thursday, August 12, 2004 5:38 PM
>>To: Walke, Rainer
>>Cc: R-devel
>>Subject: Re: [Rd] (PR#7163) Install packages does not work on Win2003
>>server
>>
>>Walke, Rainer wrote:
>>
>>
>>> >a) It works for me.
>>> >b) If it works for you on some Windows versions but not on others,
>>>why
>>> >do you think it is a bug in R?
>>>
>>> It is the first of our application that shows this problem. At least
>>>as far as I know.
>>> The installation of R works without any problem, only the addition
>>>of further packages does not. What is the difference between both
>>>installation parts? Of course you may ask what is the difference between
>>>Windows NT and Windows XP as client system. And you may ask what is the
>>>difference between a Windows NT and a Windows 2003 file server?
>>> Is R using a piece of code that Windows XP sends wrong to a Windows
>>>2003 file server?
>>>
>>> >Quite probably something is not set up correctly either in your
>>> >configuration of Windows (permissions, quota, ...) or in the
>>> >configuration of R (do you have set another library path to install
>>>to)?
>>>
>>> >Please tell us the way you tried to install the package.
>>>
>>> >Uwe Ligges
>>>
>>> What I did, was "Install packages from local zip files..."
>>>interactivly.
>>>
>>> Best,
>>> Rainer Walke
>>
>>
> 	> Is the share form which R has been started mounted on a drive
> letter or 
> 	> do you start via the UNC path?
> 	> Which package is it? Does it also happen for CRAN packages?
> 	> I guess any security setting either on the Server or the client
> are 
> 	> blocking the installation. But it is really hard to guess what it
> really 
> 	> is... You might want to ask your local IT stuff.
> 
> 	> Uwe Ligges
> 
> 	Thanks for your e-mail message. Yes, the share has been mounted on a
> drive letter P.
> 	Unfortunately, it happens for all packages starting from abind...
> 	And it happens if I load a package directly from CRAN as well.
> 	Do you know which part of the R code creates this temporary file*
> directories in the library subdirectory?

Yes, really not hard to find: The second call within function unpackPkg() in install.packages().

Uwe Ligges

> 	Rainer Walke
> 
> 
> 
> +++++
> This mail has been sent through the MPI for Demographic Research.  Should you receive a mail that is apparently from a MPI user without this text displayed, then the address has most likely been faked.   If you are uncertain about the validity of this message, please check the mail header or ask your system administrator for assistance.

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel Received on Fri Aug 13 16:57:00 2004

This archive was generated by hypermail 2.1.8 : Wed 03 Nov 2004 - 22:45:06 EST